hilpers


  hilpers > comp.os.* > comp.os.linux.configuration

 #1  
19/05/2017, 18h52
docanski
Bonjour,

Plus moyen de mettre à jour, j'obtiens systématiquement le message "Le
pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé."
S'il a disparu, c'est "à l'insu de mon plein gré" et je n'ai rien
"bricolé" dans le système.
Une idée ?

Cordialement,

 #2  
19/05/2017, 19h42
Jo Engo
Le Fri, 19 May 2017 18:52:34 +0200, docanski a écrit :

> Bonjour,
> Plus moyen de mettre à jour, j'obtiens systématiquement le message "Le
> pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé."
> S'il a disparu, c'est "à l'insu de mon plein gré" et je n'ai rien
> "bricolé" dans le système.
> Une idée ?
> Cordialement,


Alors, j'en oublie sans doute

1. remplacer provisoirement https par http dans /etc/apt/sources.list
En profiter pour virer ce que les divers blobs ont mis dedans ;)
2. purger apt-methods-https puis le réinstaller
tester (en restaurant sources.list, si ça ne marche toujours pas voir du
côt& des certificats
 #3  
19/05/2017, 20h41
Pascal Hambourg
Le 19/05/2017 à 18:52, docanski a écrit :
> Bonjour,
> Plus moyen de mettre à jour, j'obtiens systématiquement le message "Le
> pilote pour la méthode /usr/lib/apt/methods/https n'a pu être trouvé."
> S'il a disparu, c'est "à l'insu de mon plein gré" et je n'ai rien
> "bricolé" dans le système.


Vérifie les dépôts définis dans /etc/apt/sources.list et les éventuels
fichiers inclus (/etc/apt/sources.list.d/*).

S'il y a un ou plusieurs dépôts en https, vérifie si le paquet
apt-transport-https est installé. S'il ne l'est pas, il faut l'installer
(avec dpkg si nécessaire) ou commenter les dépôts en https ou les
modifier en http s'ils l'acceptent.

S'il n'y a aucun dépôt en https, alors cela signifie qu'un des serveurs
en http redirige vers https. Il est parfois difficile de trouver lequel
car il peut y avoir de multiples redirections. Normalement les miroirs
officiels de Debian ne redirigent pas en https. Les solutions sont les
mêmes que dans le cas précédent : commenter le dépôt ou installer
apt-transport-https.
 #4  
20/05/2017, 10h57
docanski
Pascal Hambourg a écrit le 19/05/2017 à 20:41 :

> S'il y a un ou plusieurs dépôts en https, vérifie si le paquet
> apt-transport-https est installé. S'il ne l'est pas, il faut l'installer
> (avec dpkg si nécessaire) ou commenter les dépôts en https ou les
> modifier en http s'ils l'acceptent.


Aucun dépôt en https.

le sources.list est simple :

deb [..] jessie main contrib non-free
deb [..] jessie-updates main contrib non-free
deb [..] jessie/updates main contrib non-free

> Les solutions sont les
> mêmes que dans le cas précédent : commenter le dépôt ou installer
> apt-transport-https.


Quand je tente d'installer apt-transport-https j'obtiens
E: oracle-java8-installer: le sous-processus script post-installation
installé a retourné une erreur de sortie d'état 1
Je vérifie quand même s'il y a un paquet cassé, c'est le cas avec emacs.
Je tente de le réinstaller et j'obtiens le même message d'erreur.
Quand je tente de réinstaller oracle-java8-installer, j'obtiens
E: Internal Error, No file name for oracle-java8-installer:amd64
Quand je veux réinstaller java8 par le terminal, j'obtiens notamment le
message d'erreur suivant :
[code]
Des erreurs ont été rencontrées pendant l'exécution :
oracle-java8-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :
Paramétrage de oracle-java8-installer (8u131-1~webupd8~2) ...
Using wget settings from /var/cache/oracle-jdk8-installer/wgetrc
Downloading Oracle Java 8...
[/code]
etc ...

Ce qui est assez curieux, c'est que je n'ai rien installé ni éliminé
depuis la dernière MAJ. Bref, je répète que je n'ai rien "bricolé" dans
le système et ses applications.

Cordialement,
 #5  
20/05/2017, 11h08
Jo Engo
Le Sat, 20 May 2017 10:57:34 +0200, docanski a écrit :

> le sources.list est simple :


Au cas où qu'y a-t-il dans /etc/apt/sources.list.d ?
 #6  
20/05/2017, 11h27
docanski
Jo Engo a écrit le 20/05/2017 à 11:08 :
> Le Sat, 20 May 2017 10:57:34 +0200, docanski a écrit :
>> le sources.list est simple :
>> Au cas où qu'y a-t-il dans /etc/apt/sources.list.d ? Bingo !


Il y avait un fichier opera-stable.list faisant appel à son dépôt en
https. Une fois cette ligne mise en commentaire, la MAJ a pu être faite.
Merci à vous deux pour l'aide !

Cordialement,
 #7  
20/05/2017, 12h10
docanski
Jo Engo a écrit le 20/05/2017 à 11:08 :
> Le Sat, 20 May 2017 10:57:34 +0200, docanski a écrit :
>> le sources.list est simple :
>> Au cas où qu'y a-t-il dans /etc/apt/sources.list.d ?

J'ai crié "victoire" trop tôt : la mise à jour s'est interrompue avec un
message d'erreur : E: oracle-java8-installer: le sous-processus script
post-installation installé a retourné une erreur de sortie d'état 1 :-(

Discussions similaires
Mise à jour debian et rollback

Debian, SSD et mise à jour des firmwares

Mise à jour de Debian

mise à jour debian


Fuseau horaire GMT +2. Il est actuellement 02h39. | Privacy Policy